Vw golf oil level workshop ***FIXED***


http://www.bba-reman.com/forums/Topic127517.aspx
Print Topic | Close Window

By Speedy - Wednesday, October 03, 2012 11:57:25 AM
Can anybody help me out ......... currently have a 52 reg Golf with the 1.6 petrol engine

Car came in with the yellow oil light flashing and the display saying check oil level ........first of we changed oil level sensor in the sump after we read the codes

That stopped the warning but after starting and stopping the car 3 times the yellow oil can came on again with the warning oil sensor workshop we did some digging about and found this can be caused by a faulty bonnet microswitch which we replaced

All good again for a few days but again the yellow oil can and oil sensor workshop has come back this comes on when you start the car then goes off however if you start and stop the car a few times the EPC light comes on then the display flashes up engine workshop when the codes are read it relates to a brake light switch fault

Are they all linked or is there something i`m missing its starting to make me tear my hair out so any help would be appreciated
By dave_1 - Wednesday, October 03, 2012 2:01:30 PM
Hi
What are the fault codes?
Have you changed the brake light switch?

Are you fault code reading all system?

Dave
By Speedy - Wednesday, October 03, 2012 2:18:25 PM
Oh god at home now not got the codes to hand

am reading it with the launch

i remember the oil level sensor code was short to positive or open circuit sporadic

brake switch code was circuit error but cant remember the numbers for the codes

brake switch code is in engine electronics and the oil level is in instruments

have fitted a VW oil level sensor and a VW brake light switch all to no avail .............i could always nip back to work and get the codes
By Disgusted - Wednesday, October 03, 2012 3:32:48 PM
If you have fitted a genuine brake switch, and you are sure it is correctly fitted (some of them are fiddly and won't work unless they're correctly mounted), check the brake light fuse, bulbs and tailgate wiring.

Re oil level sensor, wiggle test on wiring, continuity tests, short to earth and load tests. Also check for oil ingress into loom.
By SB126 - Wednesday, October 03, 2012 3:56:30 PM
Does this have a bonnet switch on the catch?

If so see if its saying closed in live Data
By Speedy - Wednesday, October 03, 2012 4:27:08 PM
SB126 (10/3/2012)
Does this have a bonnet switch on the catch?

If so see if its saying closed in live Data


Its had a new switch fitted to the bonnet catch ......................so assuming its working maybe not the best of things to do but will check in live data

Brake light fuse and bulbs checked and are working ......................

Just been back to work and puled the codes

00562 oil temperature sender-g266 sporadic open short circuit to positive

16955 p0571 brake switch (a) circuit malfunction

If thats any help
By SB126 - Wednesday, October 03, 2012 4:33:31 PM
I assume its a 4 pin brake light switch 1 circuit feeds the bulbs and the other circuit feeds the ECU again check in live data to check

brake pedal position.
By Speedy - Wednesday, October 03, 2012 4:48:40 PM
Yeah its a 4 pin switch ................is it it linked into the wiring for the oil sensor warning??
By Speedy - Tuesday, October 09, 2012 11:28:58 AM
Sorry not sure how to alter the post topic to say fixed but its fixed ..............

after much head scratching etc and then taking it to a garage with the VAG tool it turned out to be a blown fuse changed it cleared all the codes and all is well now

Still dont believe i had such a headache over a fuse but sometimes its the simple things that catch you out
By Wallyb - Tuesday, October 09, 2012 11:55:46 AM
Which fuse ?

Wally
By dave_1 - Tuesday, October 09, 2012 5:02:07 PM
Nice to hear its sorted
Which fuse?
By Speedy - Wednesday, October 10, 2012 5:16:35 AM
Wallyb (10/9/2012)
Which fuse ?

Wally


It was fuse 5 in the fusebox on the end of the dashboard drivers side ........... 7.5 amp
By lakytech - Sunday, March 27, 2016 11:34:59 AM
I HAVE THE SAME PROBLEM WITH A CAR OF A CLIENT AND YOUR POSTS HELP ME TO SOLVE THE PROBLEM.

I REPLACED OIL LEVEL SENSOR ON A GOLF 4 1,6 PETROL AND THE PROBLEM REMAINS.I CHECKED THE WIRES WERE OK.AND I CHECKED THE FUSE NUMBER 5 WAS BLOWN.IREPLACED IT AND NOW NO EPC,NO OIL SENSOR ,NO NOTHING.

THATS WHY I WANTED TO THANK YOUR SITE

REGARDS LAZ

ON BEHALF OF LAKYTECH- MINI PARTS CYPRUS

YOU SEE WE ARE MINIS SPECIALIST NO VW.

THANKS AGAIN