BBA-Reman Forums



Volvo XC90 Yaw Sensor

Posted By always baffled 10/30/2012 11:46:33 AM
Add to Favorites0
Author Message
always baffled
 Posted 10/30/2012 11:46:33 AM
Forum Apprentice

Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)

Group: Forum Members
Last Active: 8/10/2014 11:14:26 AM
Posts: 104, Visits: 841
115
Hi everyone,

Volvo XC90, 2005,

I wonder if anyone can advise on the above. The stability control light is on and a read gives

Yaw rate sensor incorrect/ no signal.

Lateral acceleration sensor incorrect/ no signal.

The codes will not clear. I found out that they suffer from water damage if the sun roof drains block and the space under the drivers seat housing the sensor fills with water, no sign of this.

We have no experiance with a system like this, A new sensor is £350.00 plus VAT so we dont want to make a mistake. I cant see anything in live data that relates to this sensor but would like to be as certain as i can before stepping off for new parts.

Advice please.

As far as i can find out the sensors are not coded but confirmation would be welcome if someone has done one.

Thanks in advance

Mike
SB126
 Posted 10/30/2012 12:13:44 PM
Forum Master Technician

Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)Forum Master Technician - (1,587 reputation)

Group: Forum Members
Last Active: 1 hour ago
Posts: 1,259, Visits: 5,106
It might not be coded, but im sure it will need to be calibrated.
K And R
 Posted 10/30/2012 1:35:11 PM
Forum Master Technician

Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)

Group: Moderators
Last Active: 51 minutes ago
Posts: 11,358, Visits: 62,623
AB

What are you reading it with ?

What are the code number,s ?

The signal is via CAN, do the other systems have codes stored ?

calibrate as follows VIDA\vehicle communications\function group 5\ brakes\ calibration.

Kev.


"If you dont KNOW how it works, don,t try to test or fix it"
GaryH
 Posted 10/30/2012 1:48:21 PM
Forum Apprentice

Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)Forum Apprentice - (233 reputation)

Group: Awaiting Activation
Last Active: 3 hours ago
Posts: 187, Visits: 10,178
233
It will need calibrating. Launch actually does these fairly easily but you will need to drive the car after calibration.

Gary
always baffled
 Posted 10/31/2012 1:14:11 PM
Forum Apprentice

Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)Forum Apprentice - (115 reputation)

Group: Forum Members
Last Active: 8/10/2014 11:14:26 AM
Posts: 104, Visits: 841
115
Thanks for the replys,

Reading with Bosch KTS

The code for the Yaw rate sensor fault is 0080

The code for the lateral acceleration sensor is 0114

There are a number of faults in the hvac, parking sensor and sunroof systems, also 8a32 headlamp flasher active too long.

The only other fault code i thought may be related is in the steering wheel angle sensor, 0016 control unit ..comunication fault.

I cannot find anything in the bosch menu that refers to calibrate the yaw rate sensor so if it is that we may be stuffed anyway.

regards,

Mike.
K And R
 Posted 10/31/2012 1:29:00 PM
Forum Master Technician

Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)Forum Master Technician - (12,699 reputation)

Group: Moderators
Last Active: 51 minutes ago
Posts: 11,358, Visits: 62,623
AB

0080 lateral accelerometer incorrect offset value.

0114 Communication with active yaw control sensor, signal missing.


KTS !!!!!


Kev.

ps SAS 0016 so it has stability control.


"If you dont KNOW how it works, don,t try to test or fix it"
10/31/2012 1:42:07 PM by K And R

Reading This Topic

Expand / Collapse

Back To Top