BBA-Reman Forums



Problem with 2006 Mondeo 2.2 TDCI Cooling Fan Permanently On

Posted By catzilla Thursday, December 05, 2013 3:36:53 PM
Add to Favorites0
Author Message
catzilla
 Posted Thursday, December 05, 2013 3:36:53 PM
Saturday Job

Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)

Group: Awaiting Activation
Last Active: Friday, December 06, 2013 1:44:29 AM
Posts: 1, Visits: 2
2
Just recently the radiator fan on my 2006 TDCI mondeo has started staying on continuously. It comes on as soon as I start the car, and remains on all the time until I switch off. I've had 2 occasions recently where the battery has gone flat and needed to jump start the car.

The temperature gauge is showing normal operating temp, and I'm not running the air con - just the normal warm air blower.

Anybody got any ideas what the problem may be.

Thanks in advance.
SB126
 Posted Thursday, December 05, 2013 3:40:03 PM
Forum Master Technician

Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)Forum Master Technician - (3,217 reputation)

Group: Awaiting Activation
Last Active: Yesterday @ 12:24:23 PM
Posts: 2,274, Visits: 14,660
There are several reasons this could happen.

Do you have any testing eqipment. ?
shaws
 Posted Thursday, December 05, 2013 6:09:13 PM
Forum Apprentice

Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)Forum Apprentice - (239 reputation)

Group: Forum Members
Last Active: Wednesday, July 03, 2019 1:13:10 PM
Posts: 151, Visits: 2,744
239
when the blower is aimed at the screen it brings the a/c on to demist automatically (at least they used to) could be one simple explanationthe battery could be on the way out, 'tis the time of year that they usually show up with more frequency
Favell
 Posted Friday, December 06, 2013 8:01:14 AM
Forum Technician

Forum Technician - (473 reputation)Forum Technician - (473 reputation)Forum Technician - (473 reputation)Forum Technician - (473 reputation)Forum Technician - (473 reputation)Forum Technician - (473 reputation)Forum Technician - (473 reputation)Forum Technician - (473 reputation)Forum Technician - (473 reputation)

Group: Forum Members
Last Active: Tuesday, March 10, 2015 8:51:01 AM
Posts: 326, Visits: 943
473
A first basic check on this will be the wiring to the fan module.

The module is fitted the fan housing and has 3 wires coming from it in a protective loom cover.
Open this loom cover and follow the wires all the way back into the main loom - you will need to remove some bits to follow it right back.

a favourite is for the small purple wire to fracture - the purple insulation may still be intact, but the wire could still be broken inside it so you need to give a good wiggle and pull.

Just make sure you have disconnected the fan before you get your fingers caught!

Fav

Reading This Topic

Expand / Collapse

Back To Top