BBA-Reman Forums



Mercedes E250 convertible issues.

Posted By Tony Curtia Saturday, November 24, 2018 9:13:01 AM
Add to Favorites0
Author Message
Tony Curtia
 Posted Saturday, November 24, 2018 9:13:01 AM
Saturday Job

Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)

Group: Awaiting Activation
Last Active: Sunday, November 25, 2018 10:21:08 AM
Posts: 2, Visits: 10
11
Help needed please.
Currently having a few problems with my 2010 merc. On first start up of the day the car has several problems. The ESP light illuminates with text warning, Run Flat tire warning shows, the passenger airbag disabled light comes on, windscreen wipers do not work nor does cruise control or speed limiter. If its not immediately apparent then depressing the brake to engage drive brings the faults up. After driving a few yards I can knock it in neutral. Turn ignition off for about 15 seconds then restart they all clear. Bloody infuriating. Had it to local diagnostics but other than brake switch change they are at a loss.Air pump for seat also in op but don't know if related. Diagnostics guy suggest one of SAMs possibly u/s. Please see video https://youtu.be/RtAoD7bn2Zk
Any help truly appreciated
Saturday, November 24, 2018 9:19:39 AM by Tony Curtia
Thema Marked As Answer
 Posted Saturday, November 24, 2018 12:22:13 PM
Forum Master Technician

Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)Forum Master Technician - (4,341 reputation)

Group: Forum Members
Last Active: Yesterday @ 6:15:09 AM
Posts: 3,278, Visits: 3,629
What a lot of symptoms! Some of them COULD be brake switch related though so, as your garage mentioned it, has that been changed and did it make any difference? What led them to think that anyway?
But I'd be surprised if that was all they could come up with, unless whatever kit they're using is particularly poor on Mercs.
For myself I would suggest getting a second opinion, make sure they tell you ALL the faults they can find recorded and if they're still no further forward then post what the faults are on here.

Peter
Tony Curtia
 Posted Saturday, November 24, 2018 5:07:45 PM
Saturday Job

Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)Saturday Job - (11 reputation)

Group: Awaiting Activation
Last Active: Sunday, November 25, 2018 10:21:08 AM
Posts: 2, Visits: 10
11
Thanks for reply Peter. Will try Camco in Warrington ( they are local ) as I'm told they are very good at both diagnosing (they have Star) and repairing defective parts. Will keep informed
McTech
 Posted Saturday, November 24, 2018 5:14:48 PM
Forum Master Technician

Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)

Group: Forum Members
Last Active: Yesterday @ 2:54:17 PM
Posts: 1,405, Visits: 12,226
T - love your movies...BigGrin

Get it on Mercedes Star. It will give you a load more data.


Possibly front SAMUnsure.

Have you had any other work done before the fault occurred?

It could have bad a Bus.

Having a poke - will go nowhere. I suggest you find a local specialist.

I think your "diagnostic guy" - "had a poke"...

Echo - Thema

Mt





I O, I O, its off to work I go!
McTech
 Posted Saturday, November 24, 2018 5:15:45 PM
Forum Master Technician

Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)Forum Master Technician - (2,095 reputation)

Group: Forum Members
Last Active: Yesterday @ 2:54:17 PM
Posts: 1,405, Visits: 12,226
slow refresh on my part - overlap post.Hehe

I O, I O, its off to work I go!

Reading This Topic

Expand / Collapse

Back To Top