BBA-Reman Forums



Ford Mondeo - Engine Malfunction

Posted By Mondeo 2020 Monday, May 13, 2019 11:24:44 AM
Add to Favorites1
Author Message
Mondeo 2020
 Posted Monday, May 13, 2019 11:24:44 AM
Saturday Job

Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)

Group: Awaiting Activation
Last Active: Monday, May 20, 2019 8:06:59 PM
Posts: 5, Visits: 53
6
I Have Ford Mondeo Zetec TDCI 140 1997CC (2 Litter) Diesel.

Car Mile Age : 130 K
Gear : Manual
Issue : Engine Malfunction




Driving along in my 13 Ford Mondeo and the engine malfunction sign comes on and car loses power.
Then all light comes up on dashboard such as ABS, ESP, Handbrake, and Engine Light.
The car was diagnosed by different garages and the Ford Dealer.
The codes is not showing specific fault and around 15 to 30 error codes appears on the diagnostic tools..
Ford Dealer they told me they can’t help.

So then all Action taken with local Garage and so far I changed the Throttle Body and have the ABS Control Module / Pomp tested by ECU tester in Heanor, Derby with no fault found.
Unfortunately Error still there!

Engine lose power while driving and then there is high rave from the engine, when pressing brakes the high raves stops,
But when pressing accelerator nothing is happening.
The car only moves in the first gear 1 push and gas pedal is useless.
When I switch engine off the error disappears, but sometimes steering locks and car not starting.
This is intermittent issue with no direction of fault allocation so far.

Any idea what could be wrong here?
Robski
 Posted Monday, May 13, 2019 12:17:39 PM
Forum Master Technician

Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)Forum Master Technician - (4,376 reputation)

Group: Forum Members
Last Active: 6 hours ago
Posts: 3,103, Visits: 54,088
Any idea what could be wrong here?
yes, you're taking it to the wrong establishments, do some homework/ask some questions & find out who in your area is the man !


Rob.
Mondeo 2020
 Posted Monday, May 13, 2019 7:17:54 PM
Saturday Job

Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)

Group: Awaiting Activation
Last Active: Monday, May 20, 2019 8:06:59 PM
Posts: 5, Visits: 53
6
Rob,

Unfortunately they don’t know in my area.
This is a strange problem.
If you know anything let me know

Cheers
K And R
 Posted Tuesday, May 14, 2019 2:20:53 AM
Forum Master Technician

Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)Forum Master Technician - (14,898 reputation)

Group: Moderators
Last Active: 46 minutes ago
Posts: 12,790, Visits: 88,440
2020

"Ford Dealer they told me they can’t help" sounds unlikely, they can help, or is it they expect it to be expensive.


Rave or Rev ?


"The codes is not showing specific fault and around 15 to 30 error codes appears on the diagnostic tools.."


What are they ????

Not sure why you had the ABS tested when it,s the engine light that comes on first.

Any wiring checks been carried out ??

Kev.


"If you dont KNOW how it works, don,t try to test or fix it"
Wednesday, May 15, 2019 2:40:40 AM by K And R
Mondeo 2020
 Posted Tuesday, May 14, 2019 4:58:08 AM
Saturday Job

Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)

Group: Awaiting Activation
Last Active: Monday, May 20, 2019 8:06:59 PM
Posts: 5, Visits: 53
6
Hi Kev,

Ford dealer they cant find fault when they plug the diagnostics tool it doesn't give them any hard code READINGS and they cant really tell why the car is loosing power and then causing this high rev!
they dont know where to start that is what they told me.

when car lose power the engine is still on with high rev and when I press the acceleration pedal it doesn't do much, like it is not working!
Then I just turn the car off and after 5-10 mints when I start the car is then back to normal only again then to happen after 1 or 2 days with same errors.



This below are the latest trouble codes after reset with Launch and Snap-on devices :

Launch:
P2125 - Engine shutoff solenoid
U0126 - Lost communication with SASM


Snap-on:
P1935 - Brake switch / sensor signal. Bus signal/message failure - not current DTC
U0155 - Lost communication with instrument panel cluster control Module - not current DTC
P193D - Cruise control multi - function input signal, alive/sequence counter incorrect / not updated - not current DTC
P2138 - Throttle/pedal position sensor/switch "D" / "E" voltage correlation - current DTC
P2125 - Throttle/pedal position sensor/switch "E" circuit - current DTC
P060D - Internal control module accelerator pedal position performance - current DTC




Wiring checks - outstanding task!

Cheers
Thema
 Posted Tuesday, May 14, 2019 7:41:14 AM
Forum Master Technician

Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)Forum Master Technician - (4,463 reputation)

Group: Forum Members
Last Active: 3 hours ago
Posts: 3,357, Visits: 3,707
Looks pretty clear cut that you have a fault in the throttle position sensor circuit (please note I said circuit, not necessarily the TPS itself!). No idea why Launch came up with that definition for P2125 as it is definitely TPS related and even less sure why Ford apparently drew a blank on it. It sounds more to me as if for some reason or other they simply weren't interested.
But at least you now have an area to concentrate on.

Peter
Andy-01
 Posted Tuesday, May 14, 2019 1:50:07 PM
Forum Technician

Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)

Group: Forum Members
Last Active: Yesterday @ 1:44:31 PM
Posts: 618, Visits: 5,588
671
What age is this ?
Several TSB's regarding known wiring issues, but that would depend on the age of the vehicle.



Brake switch signal, throttle pedal signal, those two alone point you to the starting blocks.
Follow the loom from the pedal box first.

If you post year, I can look more specific for you.

Andy
Mondeo 2020
 Posted Tuesday, May 14, 2019 4:35:21 PM
Saturday Job

Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)

Group: Awaiting Activation
Last Active: Monday, May 20, 2019 8:06:59 PM
Posts: 5, Visits: 53
6
Hi Guys

Thanks for the input
The vehicle is reg 2013.

I will surely look into those points

Thanks

Paul
Andy-01
 Posted Wednesday, May 15, 2019 7:08:06 AM
Forum Technician

Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)Forum Technician - (671 reputation)

Group: Forum Members
Last Active: Yesterday @ 1:44:31 PM
Posts: 618, Visits: 5,588
671
Good afternoon.

Throttle pedal (APP), clutch and brake pedal (BPP) switches all share a common ground at the left A Post.
I would start at that point initially !

No in-line connectors for the APP or the BPP switches, they go straight to C2 on the Body Control Module, so C2 needs examining carefully also.

Andy
Mondeo 2020
 Posted Saturday, May 18, 2019 8:34:52 AM
Saturday Job

Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)Saturday Job - (6 reputation)

Group: Awaiting Activation
Last Active: Monday, May 20, 2019 8:06:59 PM
Posts: 5, Visits: 53
6
Hi Andy,


I will look into your recommendations and above ones..

I will post feedback by end of next week

Cheers,


Paul

Reading This Topic

Expand / Collapse

Back To Top