BBA-Reman Forums



2005 Z16XEP Astra / Zafira, same engine?

Posted By sparki1 Friday, June 07, 2019 5:07:53 PM
Add to Favorites1
Author Message
sparki1
 Posted Friday, June 07, 2019 5:07:53 PM
Forum Master Technician

Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)

Group: Forum Members
Last Active: Thursday, June 13, 2019 4:14:02 PM
Posts: 868, Visits: 3,436
Evening All
A customer bought in an Astra H with a misfire once hot. Compressions cold and hot all even around 230. Engine runs lean and drops into open loop, Mil starts to flash and misfire codes start to flag, starting with cylinder 3.
Previous garage has changed plugs and coil pack twice (it’s lean ffs!) It’s then I notice the yellow scrap yard paint, and owner confirms an engine from a 2006 z16xep Zafira was fitted.
Can anyone confirm if the engine is a straight swap? They used block complete with inlet and injectors?
Thanks
Andy
SB126
 Posted Saturday, June 08, 2019 3:08:52 AM
Forum Master Technician

Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)Forum Master Technician - (3,193 reputation)

Group: Awaiting Activation
Last Active: 8 hours ago
Posts: 2,264, Visits: 14,476
I'm sure the block crank, and head are the same, but the engine dress will change, depending, on the spec, of the car. I'm guessing, you have checked fuel pressure.
Thema
 Posted Saturday, June 08, 2019 1:19:24 PM
Forum Master Technician

Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)

Group: Forum Members
Last Active: 3 hours ago
Posts: 3,394, Visits: 3,759
I'm not quite clear, did this fault appear when the engine was changed or did it start out OK and this has happened since?

Peter
sparki1
 Posted Monday, June 10, 2019 2:19:01 PM
Forum Master Technician

Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)Forum Master Technician - (1,137 reputation)

Group: Forum Members
Last Active: Thursday, June 13, 2019 4:14:02 PM
Posts: 868, Visits: 3,436
Owner not sure as he drove it from the sellers drive with no oil, got a couple of miles when engine gave up! Hence the Zafira engine it now has.!
I know! Not sort of job I would take on but he has now spent purchase price again on an engine, fitting two diagnostics coil packs and plugs!
He will also need an o2 sensor as his is cooked, so I felt a little sorry for him.
Thema
 Posted Monday, June 10, 2019 3:05:44 PM
Forum Master Technician

Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)Forum Master Technician - (4,545 reputation)

Group: Forum Members
Last Active: 3 hours ago
Posts: 3,394, Visits: 3,759
There's no way I can put this without sounding like a complete b#####d but why didn't the owner just take it straight back to the seller? Was there no oil pressure light on? Why didn't he check before he drove off?
I bought a car a couple of weeks ago (a personal toy for myself!) looked great, full service history and so on but I was going to drive it about 80 miles home so I checked the oil checked the coolant level and checked all the lights. It was all fine and I'm delighted with it but why would anyone just jump in a car they don't know and drive off?spark1 it's easy to feel sorry for people, I do know that, but it's no basis for taking work on.
Yeah, as I said at the start that sounds cruel. But to me it's realistic. IF I were you I would get out of this one and tell the customer to go back to whoever fitted the engine. I'm not getting at you, please understand that, but I wouldn't touch this one with a bargepole!

Peter

Reading This Topic

Expand / Collapse

Back To Top