BBA-Reman Forums



1.9 Nissan primastar

Posted By spence4032 Friday, November 08, 2019 10:10:26 AM
Add to Favorites0
Author Message
spence4032
 Posted Friday, November 08, 2019 10:10:26 AM
Saturday Job

Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)Saturday Job - (2 reputation)

Group: Awaiting Activation
Last Active: Tuesday, November 19, 2019 4:52:59 PM
Posts: 1, Visits: 6
2
Hi all, I’m new to the forum and hope someone can help sort out the problem with my van.Last week the van ran out off diesel even though the gauge showed 2 bars, just before it ran out the temperature gauge which never moves shot up to 2 bars from the top.
My local auto spark had a look at the van and disconnected the power to the fuel sender and said he thinks the sender is ok and he reckoned it might be the instrument cluster and advised me to get another instrument cluster and try it out which I have done.
The problem I have is I think it is something else wrong because I can see the fuel gauge getting lower from being full up but the temperature gauge does not move when I start the van or have driven it but if I turn the ignition on and off and back on again quickly the temperature gauge shoots up to 3 bars short of the top.
Hopefully someone can help me solve this problem as I don’t trust the fuel gauge at all and am wary of the van running out of fuel again.
Thanks.

Reading This Topic

Expand / Collapse

Back To Top