BBA-Reman Forums



Citroen Berlingo 2001 dash fault....

Posted By Hammond_Auto 1/2/2008 6:47:21 AM
Add to Favorites0
Author Message
Hammond_Auto
 Posted 1/2/2008 6:47:21 AM
Forum Technician

Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)

Group: Forum Members
Last Active: 7/23/2013 11:20:09 AM
Posts: 642, Visits: 1,716
699
Happy new year!

Ok i think i know the answer to this one but just making sure....

Citroen Berlingo van, 1.9D, 2001, The battery was flat so the owner jump started it, then realised that the indicators were not working and also the dashboard had no readings from the guages or the digital display... A  40A maxi fuse had blow in the engine bay and replacing this made the indicators work but stil no dash!, when the ignition is switched on the airbag light and oil pressure light come on and go off as normal when engine run up but thats all, does this sound like the dash has been spiked? I took it out and found two twisted wires in the loom so i am assuming this is a can bus system and my scanner will not communicate with the dash, fault codes in the body control module say no communication with dash.........

Any thaughts?? anyone know if BBA can test/ reman one of these units?

Thanks.

A.V.S
 Posted 1/2/2008 4:46:34 PM
Forum Tea Boy

Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)Forum Tea Boy - (92 reputation)

Group: Forum Members
Last Active: 7/14/2010 6:38:50 AM
Posts: 89, Visits: 855
92
Sounds like jump leads wrong way! Lost track of how many clusters we've c hanged on modern cars through this. It always seems to be the cluster that goes instead of other ecu's, can only assume its the direct connection to engine block. Nearly every customers' neighbour was determined this wasn't the cause. They nearly always crack after showing them the burnt cluster tracks/PCB!!
cl1101
 Posted 1/2/2008 5:41:12 PM
Saturday Job

Saturday Job - (8 reputation)Saturday Job - (8 reputation)Saturday Job - (8 reputation)Saturday Job - (8 reputation)Saturday Job - (8 reputation)Saturday Job - (8 reputation)Saturday Job - (8 reputation)Saturday Job - (8 reputation)Saturday Job - (8 reputation)

Group: Forum Members
Last Active: 1/2/2008 5:36:31 PM
Posts: 8, Visits: 28
8
Hi,

we had a berlingo in over the holiday period with the same fault on the dash, it turned out to be a 7.5 amp fuse in the top right of the fuse board by the steering column. Don't know what its for but it worked.... and on christmas eve at 4.30pm..... i didn't really care either!!!!

Maybe way off the mark but it worked for us.

regards

Colin

Hammond_Auto
 Posted 1/3/2008 4:05:43 AM
Forum Technician

Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)Forum Technician - (699 reputation)

Group: Forum Members
Last Active: 7/23/2013 11:20:09 AM
Posts: 642, Visits: 1,716
699
Thanks guys, I have checked all the fuses but will double check!

Reading This Topic

Expand / Collapse

Back To Top